Cadillac STS The newest installation of the performance sedan from Cadillac, having replaced the Seville

2005 STS acceleration "bucking"

  #1  
Old 04-12-2012, 09:55 PM
Junior Member
Thread Starter
Join Date: Apr 2012
Posts: 2
Default 2005 STS acceleration "bucking"

I have a 2005 STS with the 3.6. I have a constant problem that when accelerating the car will lurch or buck like a really bad misfire is happening. Usually no lights flash. I have even been driving down the street and Onstar has called me asking if everything was ok?! I couldn't tell if anything was wrong but they said that the engine was misfiring...no idiot lights. I took the car to the dealer and they replaced the coil and it seemed to fix the problem. But, then it came back, probably worse. No codes. Today it bucked so violently that the check engine light blinked then stayed on solid. I called Onstar but by the time they were able to do a diagnostic the light was off and the car was running fine. They said they couldn't see any codes and to call back when the light was on. HELP please.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
arendina
General Tech
2
10-13-2012 12:44 AM
missileJ
General Tech
11
05-08-2012 01:28 PM
Landrjeski
Cadillac STS
2
05-18-2011 05:59 PM
bsstyle2011
Cadillac Seville
6
03-22-2011 04:07 PM
A342195
General Tech
4
03-22-2009 06:48 PM


Thread Tools
Search this Thread
Quick Reply: 2005 STS acceleration "bucking"


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.