Cadillac Escalade The full sized sport utility vehicle that has combined the versatility of an SUV with the luxury associated with the Cadillac name

I NEED HELP!!!! Random Misfire?????

  #1  
Old 10-08-2008, 09:06 AM
Thread Starter
Join Date: Oct 2008
Posts: 2
Default I NEED HELP!!!! Random Misfire?????

Ok, so here it is...I have a 2002 Escalade, 6.0L V8. It just passed a 100,000 miles with no know mechanical problems. About two weeks ago it started acting funny during rapid acceleration. IfI just coasted up to 40 or 50 MPH there was no issue, but as soon as I slam the gas to merge/pass or whatever, the engine would get louder but the MPHs and RPMs wouldn't increase; the check engine light would flash; and if I didn't let off the pedal I get this loud clicking/knocking sound. Once I let off the gas the sound would stop but I still couldn't accelerate.

It has gotten to the point now where it is pretty much un-drivable. The engine light remains on and it has a very rough idle. The only code that I am receiving from the engine light is P0300 - Random Misfire.

Here is what I have done so far...

- Replaced all plugs
- Replaced all plug wires
- Replaced the Mass Air Flow Sensor
- Replaced the air filter
- Replaced the fuel filter
- Put injector cleaner in the tank
- Did a spark check on all coils

I am to the point where I think I may need to take it to the dealer because I am at a total loss. I am past the "simple" fixes and I fear that I am going to be getting into much more complicated repairs. The fact that it is a "random" misfire makes me believe that it isn't an injector, or coil, or anything that would normally result in one cylinder misfiring.

If there is anyone out there that has experienced a similar issue, or can think of any other explaination, please let me know your thoughts.

Thanks.
 
  #2  
Old 01-02-2012, 07:33 PM
Junior Member
Join Date: Jan 2012
Posts: 1
Default Random misfire

I'm having the same problem right now did you ever find out what was wrong with yours ?
 
  #3  
Old 01-23-2012, 08:36 PM
Junior Member
Join Date: Jan 2012
Posts: 2
Default

Random Misfire PO300
New forum member.
Have a 99 Escalade w/5.7L V8.

Check engine light came on during entrance ramp acceleration. Max speed was about 50mph. Common Error codes PO300, PO307 and PO305.
  1. Replaced spark plugs
  2. Replaced air filter
  3. Replaced fuel filter
  4. Replaced distributor rotor
  5. Added Techron fuel system cleaner (per instructions)
This worked temporarily.


When problem returned:
  1. Changed fuel type from low grade to mid-grade detergent gasoline
  2. Noticed coolant system had lost some coolant. Coolant wasn't leaking outside engine, but was being burned off in the combustion process (intake gasket failure). Added more coolant plus coolant system sealer.
Might want to check the following too.
  1. GM Dex-Cool Coolant system issue with intake gasket leaks/failure.
  2. Fuel Pressure Regulator (easily damaged by some types of injector cleaners)
  3. Fuel Injectors (deposits from low grade fuel may result in injector failure/performance issues)
 

Last edited by Earth Rider; 11-01-2012 at 02:16 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Baldeeny
General Tech
0
02-18-2012 10:59 PM
WhoDey4Life
General Tech
0
10-08-2008 09:27 AM
hrnyhg
Cadillac Deville
2
03-05-2008 11:56 AM
HondaMan
Private For Sale/Trade Classifieds
0
08-23-2006 05:56 AM
stealtreasure
General Tech
0
07-02-2006 06:51 AM


Thread Tools
Search this Thread
Quick Reply: I NEED HELP!!!! Random Misfire?????


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.