Automatic Transmission Question

  #1  
Old 04-16-2019, 01:54 PM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 4
Default Automatic Transmission Question

I Have a 2016 SRX that just turned 50,000 miles. I was able to suck out 61 ounces of old transmission fluid and replaced with almost the same amount of Dexron VI. Then I drove it to warm it up and check the level. With all my older vehicles the dipstick read low when cold and higher when hot. My problem now is it does just the opposite. It reads at the very maximum level when cold and looks to need more added when it is checked hot. I am thinking I need to get it to proper level after the fluid is hot and disregard the high level cold reading. That being said I have been wrong before so I need to be sure. Can someone enlighten me on whats going on ?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Stealth
Transmission Tech
19
02-21-2013 12:35 AM
jimsheila
General Tech
8
12-12-2011 09:23 PM
ahmaduhhs
Automatic Transmissions
0
04-15-2009 03:04 PM
nobbyneumann
Private For Sale/Trade Classifieds
0
06-14-2007 10:44 AM
simjack
Private For Sale/Trade Classifieds
0
01-09-2005 10:04 AM


Thread Tools
Search this Thread
Quick Reply: Automatic Transmission Question


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.