Cadillac STS The newest installation of the performance sedan from Cadillac, having replaced the Seville

running hot

  #1  
Old 12-02-2004, 10:10 PM
Thread Starter
Join Date: Dec 2004
Posts: 5
Default running hot

Since my water pump went out I've had the waterpump, radiator, thermostat, waterpump pully replaced. Now the car runs hot after 3-5 minutes. What could it be?
 
  #2  
Old 12-16-2004, 01:21 PM
Join Date: Dec 2004
Location:
Posts: 32
Default RE: running hot

Check your exhaust if you see white smoke coming out of the tail pipe your probably looking at a bad head gasket do you have an aluminun v6 or v8 engine
 
  #3  
Old 08-23-2005, 12:17 PM
Join Date: Aug 2005
Posts: 2
Default RE: running hot

HOW HARD IS IT TO CHANG A WATER PUMP ON A 95 STS
 
  #4  
Old 11-08-2005, 01:20 PM
Administrator
Join Date: Mar 2005
Posts: 466
Default RE: running hot

ive never done one, but i think that its going to be a pain.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Mags1
Cadillac Deville
6
11-19-2010 07:37 PM
needhelp
General Tech
5
04-14-2007 04:45 AM
needhelp
General Tech
2
06-15-2005 11:51 AM
needhelp
Member Introduction
1
12-16-2004 06:12 PM


Thread Tools
Search this Thread
Quick Reply: running hot


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.