Cadillac STS The newest installation of the performance sedan from Cadillac, having replaced the Seville

Likely Electrical Problem

  #1  
Old 03-05-2007, 11:21 AM
Thread Starter
Join Date: Dec 2005
Posts: 16
Default Likely Electrical Problem

Dear Colleagues,

I have a 1998 Seville STS with around 68,000 miles. Last night, I started the car, and the radio would not turn on. Hmmnnn, I decided to turn off the car and restart...well, the car then would start for a second, then die. At last inspection, the interior lights weren't working, no dash lights, and the power door locks are dead. It will start and then die rather instantantaneously. Any thoughts? It is in the shop now being diagnosed.

Many Thanks,
Alan
 
  #2  
Old 03-05-2007, 01:13 PM
Thread Starter
Join Date: Dec 2005
Posts: 16
Default RE: Likely Electrical Problem

Mechanic says it is a problem with the Pass Key system..got to go to the dealership..any words of wisdom?
 
  #3  
Old 03-05-2007, 01:46 PM
Katzmans Caddy's Avatar
Super Moderator
Join Date: Dec 2006
Location: Toronto, CANADA
Posts: 1,461
Default RE: Likely Electrical Problem

May sound a bit rudementary, change to another key. Those little pellets sometimes wear out and send sketchy signals to the computer. I have experience this myself in an older GM vehicle I used to have. Key change solved my problem. I was lucky and they gave me three when I bought that car new, so my wife still had her's which worked well.
 
  #4  
Old 03-21-2007, 12:29 AM
Join Date: Mar 2007
Posts: 2
Default RE: Likely Electrical Problem

ORIGINAL: Katzmans Caddy

May sound a bit rudementary, change to another key. Those little pellets sometimes wear out and send sketchy signals to the computer. I have experience this myself in an older GM vehicle I used to have. Key change solved my problem. I was lucky and they gave me three when I bought that car new, so my wife still had her's which worked well.
Doesn't sound like the pass key issue to me. I'vehadTHAT problem and it is just a shutdown ofthe starting process.I had similar light issues with my '90 Seville (similar to the STS, yes). Turned outto be body controller.Replaced that and MOST of the issues went away. Still has issue with the power locks and door sensors. BC wouldn't explain the engine running then stopping thing. Have you run the OBD?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Jwilly
Cadillac Escalade
1
10-27-2007 10:48 AM
Cadillac Kid
Cadillac STS
1
11-10-2006 12:41 AM
Vasile2
General Tech
0
09-22-2006 10:47 PM
devilleconcours100
General Tech
1
08-29-2006 12:50 AM
ghostdeville
Cadillac Deville
1
06-23-2006 07:06 PM


Thread Tools
Search this Thread
Quick Reply: Likely Electrical Problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.