Cadillac STS The newest installation of the performance sedan from Cadillac, having replaced the Seville

95 STS electrical problem?

  #1  
Old 11-08-2006, 10:20 PM
Thread Starter
Join Date: Oct 2006
Posts: 28
Default 95 STS electrical problem?

My car seems like it resets itself when I put the high beams on...and just sitting there ideling.The monitoring system starts up again,the cd player shuts off and comes on again,whats going on with my car?Its not effecting the cars engine performance ,its that its annoying and bothering me,because I don't know why this is happening.If anybody had this problem or knows what it could be...let me know please and thank you.
 
  #2  
Old 11-10-2006, 12:41 AM
Thread Starter
Join Date: Oct 2006
Posts: 28
Default RE: 95 STS electrical problem?

I found the problem...just the possitive connectors going to the battery(corroded and broken wires)!!!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RayCaddy
Automatic Transmissions
7
07-12-2011 01:21 PM
joebar
Cadillac STS
0
11-22-2008 04:29 PM
Vasile2
General Tech
0
09-22-2006 10:47 PM
devilleconcours100
General Tech
1
08-29-2006 12:50 AM
ghostdeville
Cadillac Deville
1
06-23-2006 07:06 PM


Thread Tools
Search this Thread
Quick Reply: 95 STS electrical problem?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.