Cadillac STS The newest installation of the performance sedan from Cadillac, having replaced the Seville

1st time caddy owner 2000 STS

  #1  
Old 07-26-2014, 01:26 PM
Junior Member
Thread Starter
Join Date: Jul 2014
Posts: 2
Default 1st time caddy owner 2000 STS

I just bought this car knowing there were electrical issues. I have electrical background. First, I have no data input from any of the module. Ran diagnostics and no codes and no data. I also seem to have a short in circuit ELS maxi fuse. Could this be the cause to the loss of communication?
I do not have schematics, other than Hayes book (useless).
Any help would be greatly appreciated.
 
  #2  
Old 07-27-2014, 10:13 AM
Junior Member
Thread Starter
Join Date: Jul 2014
Posts: 2
Default No Data inputs, 2000 STS

Ran diagnostic test and no codes, no X data.
Any suggestions?
Seem to only have primary functions. No windows, radio, powerdoor locks, sunroof either. Just headlights, directional and hazards.
 
  #3  
Old 07-30-2014, 08:09 PM
slowroll's Avatar
Tech Certified Members
Join Date: Oct 2007
Location: in the mitten
Posts: 3,160
Default

there should be U codes, no power to module will cause data troubles. Battery cable corrosion is a common cause of trouble.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bigzo
Member Introduction
0
10-13-2010 07:17 PM
beddism-caddy
Member Introduction
0
02-21-2009 04:59 PM
starydr
Cadillac Eldorado
3
10-14-2007 01:52 AM
MIarkowski
Cadillac Deville
1
05-16-2007 08:07 AM
MIarkowski
Cadillac Deville
6
05-04-2007 02:00 AM


Thread Tools
Search this Thread
Quick Reply: 1st time caddy owner 2000 STS


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.