missing and loss of power - Cadillac Forum - Enthusiast forums for Cadillac Owners


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-22-2018, 04:53 PM
Junior Member
Thread Starter
 
Join Date: Jun 2018
Posts: 1
Default missing and loss of power

i have a 96 fwb it misses at idle and when I try to step on it a little it hesitates and takes a while to get up to speed it didn't start till after my opti went out changed it and a couple days later it started missing bad and check engine light started flashing so changed the plugs and wires, tps, fuel filter, fuel pump was changed like a year ago..... my mechanic told me to get the icm checked since all accrued after opti failed said it could have killed it also......any other thoughts, thanks
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2005 Cadillac STS 3.6 loss of power and abnormal noises after cold start PLEASE HELP! Floyd Rivers Aluminum Block V8s 1 10-08-2012 10:19 PM
2005 sts v6 loss of power and weird noises after cold start please help!! Floyd Rivers General Tech 0 09-29-2012 09:54 AM
Loss of power and only 12 mpg? runtime Cadillac Fleetwood 6 04-17-2008 03:36 PM
Loss of Electrical power mistrbbkp General Tech 2 07-18-2007 03:01 AM
Engine Power Loss: Low Range Perfomance On mar322 Cadillac SRX 0 05-30-2007 05:11 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 02:24 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.