Cadillac STS The newest installation of the performance sedan from Cadillac, having replaced the Seville

Serious Electrical - 99 Cadillac SLS. Help?

  #1  
Old 08-23-2010, 11:50 AM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 3
Default Serious Electrical - 99 Cadillac SLS. Help?

I have a 99 Cadillac SLS with a serious electrical issue. It has been troubleshot to death, perhaps someone can offer some unique insight.

While driving, dash readout suddenly goes extra bright, the "traction control" and "security" lights will appear, the info readout will display any of the following randomly and sporatically from one second to the next...
  1. service air bags (always appears)
  2. service security system (always appears)
  3. speed limited to 90 mph (seldom, but does appear)
Gas gauge goes to Empty, and when it does this, the air conditioner stops blowing cold air. This can last anywhere from a couple seconds to 10 minutes, theres no rhyme or reason to it. When gas gauge needle goes back up, air goes back on, but does necessarily mean all other icons go back to normal. All errors are random.

Usually, but not always, when car starts going bonkers, windows will stop rolling up or down, and car will lock me in. This may or may not reset itself before the end of the car ride. I will sometimes have to restart the car in order for all features to reset and to exit the vehicle. Keyless entry may or may not reset itself.

I have had computers read the computer (radio) and replace modules in the car.... didnt fix problem... costed me hundreds of dollars

Has ANYONE had similar problems?
 
  #2  
Old 08-26-2010, 11:02 AM
Senior Member
Join Date: Oct 2007
Location: Tampa, Florida
Posts: 230
Default

Sorry I can't help you with this one but it sounds like it's time to say good bye to your car. Sometimes these cars can become cash cows.
 
  #3  
Old 10-16-2010, 11:20 PM
rickyd's Avatar
Tech Certified Members
Join Date: Jul 2007
Location: pennsylvania
Posts: 1,319
Default

i think i can help.... do you still have the car???
 
  #4  
Old 10-17-2010, 02:24 PM
rickyd's Avatar
Tech Certified Members
Join Date: Jul 2007
Location: pennsylvania
Posts: 1,319
Default

shoot.... this is right up my alley... lol sorry i didnt see sooner. check E-Ghosts, my post for help.
 
  #5  
Old 03-31-2011, 12:15 AM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 3
Default

RickyD - hopefully you will read this - I gave up hope on this forum and all else but do still have the car... Ill try to find this post youre talking about
 
  #6  
Old 03-31-2011, 02:40 AM
Senior Member
Join Date: Aug 2010
Posts: 214
Default

Sounds really nasty.You could always donate the car to the Blair Witch Project.
 
  #7  
Old 03-31-2011, 06:20 AM
rickyd's Avatar
Tech Certified Members
Join Date: Jul 2007
Location: pennsylvania
Posts: 1,319
Default

Gee sure sounds like electrical issue I call E-Ghost is present.. )) if all interior electrics are going nuttzy in the 1999 Seville, chances are the Rear Integration Module......(RIM) is not doing what it should. All interior electronics pass thru the RIM. The RIM is located behind the passenger side rear seat back. It is a very simple change.. if no one has looked at this or changed this ........do it..!! I think it will take care of your E-Ghosts. Please let me know...))
Rickyd
 
  #8  
Old 04-01-2011, 10:40 PM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 3
Default

Hi Ricky... What if I told you the RIM module has been replaced? A $900 Dealership job.

I'm curious if the other caddy owners with the same problem had anything after market installed in their cars or if everything was stock and untouched.
 
  #9  
Old 04-02-2011, 07:21 PM
rickyd's Avatar
Tech Certified Members
Join Date: Jul 2007
Location: pennsylvania
Posts: 1,319
Default

Originally Posted by misslunch View Post
Hi Ricky... What if I told you the RIM module has been replaced? A $900 Dealership job.

I'm curious if the other caddy owners with the same problem had anything after market installed in their cars or if everything was stock and untouched.
do you have an auto start installed in your car??? and if so, was this mentioned before??? i didnt notice.. this could be your problem!!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MelleMel84
General Tech
1
09-30-2013 03:51 PM
jaffarski
Tires and Wheels
4
04-02-2009 08:47 PM
1989 fleetwood
Suspension sponsored by Arnott Inc.
24
11-21-2008 01:55 PM
caddyman96
Cadillac Seville
2
12-24-2006 12:21 PM


Thread Tools
Search this Thread
Quick Reply: Serious Electrical - 99 Cadillac SLS. Help?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.