93 BROUGHAM!!!LEAKING

  #1  
Old 11-01-2007, 09:09 AM
Thread Starter
Join Date: Oct 2007
Posts: 14
Default 93 BROUGHAM!!!LEAKING

I finally purchase my cadillac..I bought a 93 brougham 5.7L 350..Beautiful red on burgundy leather top with only 86,000 on it for $4500..Thats besides the point..I had 2 drive about 40 miles to pick up but it was worth it..next to the fire wall behind the end of the front passenger carpet I notice there is water leaking in through it when I got home ..Plus my light tail light at night doesn't turn on but it does when I apply brake..Any help please thanks sorry for the long story
 
  #2  
Old 11-01-2007, 06:30 PM
Super Moderator
Join Date: Feb 2007
Posts: 1,646
Default RE: 93 BROUGHAM!!!LEAKING

Slowroll will correct me if I'm wrong.

Heater core??

Bulb??
 
  #3  
Old 11-01-2007, 09:35 PM
slowroll's Avatar
Tech Certified Members
Join Date: Oct 2007
Location: in the mitten
Posts: 3,160
Default RE: 93 BROUGHAM!!!LEAKING

Responded to other post, it's possible. The question is : Is water clear or tinted? tinted - heater core. clear 2 possibles
 
  #4  
Old 11-01-2007, 11:48 PM
Thread Starter
Join Date: Oct 2007
Posts: 14
Default RE: 93 BROUGHAM!!!LEAKING

Slowroll !!!I wipe the water with white rag and it seems pretty clear...I also got the dash lights workin ,it was a faulty fuse in the engine compartment..I check them all with a electrical fuse tester..But now for some odd reason my milage and mph gauges doesn't run but is on..
 
  #5  
Old 11-02-2007, 08:34 PM
slowroll's Avatar
Tech Certified Members
Join Date: Oct 2007
Location: in the mitten
Posts: 3,160
Default RE: 93 BROUGHAM!!!LEAKING

Clear - evaporator drain or water leak at windshield or sunroof if equipped. Speedo - ses light on?
 
  #6  
Old 11-04-2007, 10:44 PM
Join Date: Jul 2007
Location: SoCali
Posts: 54
Default RE: 93 BROUGHAM!!!LEAKING

I had to drive about 120 miles round trip to get my 94 Fleetwood. Its was $3,600 with 120k miles. I'm getting a 97 Towncar too for $1,000
 
  #7  
Old 11-05-2007, 10:37 AM
Thread Starter
Join Date: Oct 2007
Posts: 14
Default RE: 93 BROUGHAM!!!LEAKING

I use the car all weekend with the air on and I didnt see no water ..So I guess it is the windshield..But no speedo light on!!
 
  #8  
Old 11-05-2007, 09:06 PM
slowroll's Avatar
Tech Certified Members
Join Date: Oct 2007
Location: in the mitten
Posts: 3,160
Default RE: 93 BROUGHAM!!!LEAKING

Is Service Engine Soon light on? Is speedometer blank?
 
  #9  
Old 11-06-2007, 02:51 PM
Thread Starter
Join Date: Oct 2007
Posts: 14
Default RE: 93 BROUGHAM!!!LEAKING

No check engine on..Speedometer on 0 and miles dont run but fuel measurement works fine..
 
  #10  
Old 11-06-2007, 07:38 PM
slowroll's Avatar
Tech Certified Members
Join Date: Oct 2007
Location: in the mitten
Posts: 3,160
Default RE: 93 BROUGHAM!!!LEAKING

Pcm send data to cluster for speedo. No ses should mean pcm is getting signal from vss, and problem is pcm,cluster or wires between them. you will need to take to shop or guess with your money.
 

Thread Tools
Search this Thread
Quick Reply: 93 BROUGHAM!!!LEAKING


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.