Cadillac Eldorado This classic Caddy still stands today for complete luxury.

2001 Eldorado stalls after start, no relevant codes

  #1  
Old 12-26-2018, 06:40 PM
Junior Member
Thread Starter
Join Date: May 2018
Location: Upstate NY
Posts: 15
Default 2001 Eldorado stalls after start, no relevant codes

Northstar 4.6L , 130K miles. Stalls after start a half dozen times before finally staying running. Only semi-relevant code is P0507, high idle detected - that was a problem a few months ago, cleared itself.

What I have done:
Cleaned MAF sensor screen, cleaned throttle body (it wasn't really too dirty).
Looked for vacuum line breaks, sloppy connectors, etc - did't find any.
Checked air filter, clean, and the air filter housing is properly closed.
Threw a few cans of SeaFoam in the tank, ran the tank down, refilled, one more can, no help.

Any ideas?
thanks
Art
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
WebJunkie
Cadillac Seville
0
06-10-2018 02:47 PM
Stephen Kirby
General Tech
8
04-28-2014 11:56 PM
RoyalFleet
Member Introduction
3
08-13-2010 02:58 PM
jaymit
Cadillac Deville
4
08-08-2008 05:31 PM
justtalkin
Cadillac Deville
2
05-23-2008 10:30 PM


Thread Tools
Search this Thread
Quick Reply: 2001 Eldorado stalls after start, no relevant codes


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.