Cadillac CTS The mid-sized sedan that has grown the popularity of the Cadillac brand with it's low price and sleek styling

2010 CTS 3.0 EVAP Code

  #1  
Old 08-17-2016, 05:27 PM
Junior Member
Thread Starter
Join Date: Aug 2016
Posts: 3
Thumbs up 2010 CTS 3.0 EVAP Code

My 2010 CTS 3.0l just threw a P code for EVAP Purge Valve High - P0496. Normally this requires cleaning or replacement of the EVAP Purge Valve. This time I found the vacuum pipe connecting the EVAP to the air intake had came loose. This line connects on the drivers side rear top side of the engine. Once reconnected I cleared the code and so far it has not reoccurred.

Lesson - check vacuum lines often to ensure they have not become disconnected.

A good link on OBD codes and this P code in particular is:

http://www.obd-codes.com/p0496
 
  #2  
Old 08-18-2016, 02:10 PM
slowroll's Avatar
Tech Certified Members
Join Date: Oct 2007
Location: in the mitten
Posts: 3,160
Thumbs up

welcome and thanks for sharing
 
  #3  
Old 08-23-2016, 09:16 AM
Junior Member
Thread Starter
Join Date: Aug 2016
Posts: 3
Default

Looks like I made a mistake above post. This vacuum tube is part of the PVC system and connects to the valve cover on the drivers side of the engine.

The P0496 code is back.

When I filled up last time, my car did not want to start (cranking but did not start) until I held down the gas pedal.

Earlier when I filled the tank, the car did start but idle was very rough until I pressed the gas pedal and revved the engine.

Could this all be a be a bad EVAP purge control valve?
 
  #4  
Old 08-23-2016, 11:54 AM
slowroll's Avatar
Tech Certified Members
Join Date: Oct 2007
Location: in the mitten
Posts: 3,160
Default

possibly if it was causing a vacuum leak. Try clean throttle bore. If there is a lot of carbon it can cause pedal to be depressed to start engine. There is a special policy related to throttle body which MAY apply you could go by dealer and see.
 
  #5  
Old 08-28-2016, 02:46 AM
Junior Member
Thread Starter
Join Date: Aug 2016
Posts: 3
Default

I replaced the EVAP Purge Valve located on the top of the engine on the passenger side. The old valve was stuck in the open state. Simple to replace. So far, my CTS is behaving properly. I still need to fill up and see if it has a hard time starting. Seems to be a similar problem to a post in the SRX section of the forum.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mikehud
Cadillac SRX
2
01-23-2019 12:57 PM
bigbri7870
Cadillac Escalade
0
04-20-2016 12:53 PM
joshholman
Cadillac STS
0
03-13-2010 06:25 PM
larrytronics
General Tech
1
06-03-2009 12:53 PM
sulup
General Tech
1
01-10-2008 10:38 PM


Thread Tools
Search this Thread
Quick Reply: 2010 CTS 3.0 EVAP Code


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.