Intro and quick questions - Cadillac Forum - Enthusiast forums for Cadillac Owners

Aluminum Block V8s 4.1, 4.5, 4.6, and 4.9 liter engines.

Intro and quick questions

Reply

 
 
 
  #1  
Old 04-04-2018, 05:54 PM
Junior Member
Thread Starter
Join Date: Feb 2018
Location: San Angelo Tx.
Posts: 2
Default Intro and quick questions

Hello all. I have a 97 Deville that I bought dirt cheap. I did my homework and already knew the head gasket/bolt problem had claimed this engine. The battery was dead when I went to buy, but I didn't care because of the price I paid. The IPC is blank, so I don't even know the mileage but was informed it was around 150k. When I restored battery power and cranked it, thick clouds of white smoke billowed out of the tailpipes. For grins I went ahead and ran a block tester, it failed immediately. SHUT IT DOWN!!! So... I ripped out the engine, tore it down, cleaned, and inspected all components. I was shocked at how clean this engine was! I started making my parts list and set out to get another Northstar back on the road.

Replaced: All bearings, piston rings, oil pump, balancer, oil manifold, 13 of 32 lifters, misc. timing components, and all seals/gaskets. I went through the heads and did a valve job. The heads and valves were the only parts that had me worried, as they were the dirtiest parts compaired to the bottom end. Yet after the work, Im happy with them and think they will last forever with proper care.

Im currently waiting on head studs to arrive so I can proceed, but I do have one small question. I have a second design rear main crankshaft seal I need to install. Im a penny pincher and don't want to buy a 300$ tool for the install. Has anyone found a way to get buy without? I work at a tractor repair shop and we often times make our own special tools, so Im not against the idea. My engine is still on the stand, so I cant even try. If these studs don't get here soon, I might remove it from the stand and play around with seal install.

BTW: I bought head studs 2-26-18. I got a message on 3-14-18 that they had shipped and was given a tracking number. As of today, 4-4-18, tracking number show they haven't even arrived at a facility yet. I believe they are at a customs office, is this a normal wait???

Thank you to all who reply, I look forward to many years of ownership!
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
CTx-V
Member Introduction
0
03-31-2011 09:03 PM
Stealth
Cadillac BLS
3
06-01-2008 08:09 PM
ThePiercer
Member Introduction
2
08-13-2007 01:39 PM
mattillac
Member Introduction
1
05-21-2007 07:35 PM
aviator
Member Introduction
1
08-08-2005 10:05 PM


Thread Tools
Search this Thread
Quick Reply: Intro and quick questions


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.