Help Needed - Cadillac Forum - Enthusiast forums for Cadillac Owners


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-17-2017, 08:13 PM
Junior Member
Thread Starter
 
Join Date: Mar 2017
Posts: 2
Default Help Needed

I thought I would save myself some money on my 2009 escalade. A mechanic told me one of the front struts was locked up. The cost on the strut alone is over 400.00. I watched you tube videos and decided I could do it myself. I got the old strut off relatively easy. I used the spring compressors to take the strut loose from the coil spring without any trouble. I put the new strut back in the coil spring and tightened everything up.
The problem is when I tried to put it back in place the strut is not compressed enough to get back in the same place it came out of.
I can't seem to get the strut to compress at all so it will fit.
it's hard for me to believe there is no give in the new strut. If it's this hard won't it be a hard ride? That is, of course if o ever get it back together.
can anyone tell me how to get the strut back in place?
Reply With Quote
  #2  
Old 03-20-2017, 02:22 PM
slowroll's Avatar
Tech Certified Members
 
Join Date: Oct 2007
Location: in the mitten
Posts: 2,980
Default

So you took the front strut apart. Change the strut and put it back together, bolted it back in truck and suspension won't depress so front is sitting too high?
Reply With Quote
  #3  
Old 03-20-2017, 03:09 PM
Junior Member
Thread Starter
 
Join Date: Mar 2017
Posts: 2
Default

Yes, that is correct. The A frame doesn't seem to be apart enough to get the new strut in. The old strut was seized up and the distance from end to end was 19 1/2" The new strut is 21" and I can't seem to get it to fit. Do I need to disconnect some parts to open the A frame wider?
Reply With Quote
  #4  
Old 03-25-2017, 09:54 AM
slowroll's Avatar
Tech Certified Members
 
Join Date: Oct 2007
Location: in the mitten
Posts: 2,980
Default

IDK, IMO you need someone local to look at what you got. If the shock won't compress it sound like you have a defective or damaged shock. The spring not the shock supports the vehicle. If you take sway bar link loose you may get some additional travel.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help needed Nunob Cadillac CTS 0 11-05-2010 09:51 AM
Help Needed to Clean Drain Tubes 05Escalade Cadillac Escalade 1 03-30-2010 06:14 PM
help needed joshholman Aluminum Block V8s 6 03-20-2010 05:18 PM
N* timesert help needed, please davidawg Aluminum Block V8s 3 12-15-2008 06:40 PM
GM Cadillac Allante microfich reader help needed Stealth Cadillac PininFarina Allante 0 10-24-2007 04:57 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:09 AM.