Ignition ON, Fuel Pumps Continues Running - Cadillac Forum - Enthusiast forums for Cadillac Owners

Ignition ON, Fuel Pumps Continues Running

Reply

 
 
 
  #1  
Old 02-11-2013, 10:39 PM
Junior Member
Thread Starter
Join Date: May 2012
Posts: 8
Default Ignition ON, Fuel Pumps Continues Running

Normally upon starting, the fuel pump shuts down after two seconds in ignition ON mode...then you crank and start engine...pumps turns ON again. Well, my pump does not shut OFF upon initialization...it keeps running...forever!

What controls this and how is it fixed? New computer and relay for fuel pump had no effect.

Frank
 
Reply With Quote
  #2  
Old 02-11-2013, 10:42 PM
Junior Member
Thread Starter
Join Date: May 2012
Posts: 8
Default Btw...

1983, 4.1

Frank
 
Reply With Quote
  #3  
Old 02-12-2013, 03:32 PM
Senior Member
Join Date: Aug 2010
Posts: 214
Default Fuel Pump

Could be the contacts in the fuel pump relay stuck in the closed position, pull out the relay and tap it against some thing and then put it back in to see if that helps.
 
Reply With Quote
  #4  
Old 02-12-2013, 04:21 PM
Junior Member
Thread Starter
Join Date: May 2012
Posts: 8
Default Fuel Pump Relay

I tried switching out two relays...swapped them, really. Still continued to pump. One of the relays is new.

Frank
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
brecskel
General Tech
0
05-20-2014 03:52 PM
peace707
Cadillac STS
2
12-07-2006 02:05 AM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory