A/C problems - Cadillac Forum - Enthusiast forums for Cadillac Owners


Cadillac Seville The Cadillac luxury combined with a performance sedan feel

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 05-03-2018, 05:10 PM
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 2
Default A/C problems

I have a 2001 Seville sts. I recently put a can of r134a in and everything was working fine but the next day it quit blowing cold. Any advice as to why it would just stop? Maybe bad compressor or does the compressor need to be reset? Thanks in advance...
Reply With Quote
  #2  
Old 05-09-2018, 11:59 AM
Vinn's Avatar
Junior Member
 
Join Date: Mar 2018
Posts: 18
Default

the compressor needs oil along with the refrigerant. some oils have a "stop leak effect". on my 88 coupe de ville, I just disconnected the wires on the compressor -because - I don't want to deal with with it now. as I was advised by a good mechanic. on older model cars you could just remove the v belt. vin
Reply With Quote
  #3  
Old 05-11-2018, 02:08 PM
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 2
Default

So r u sayn I can just disconnect the wires to the compressor and that could possibly fix the problem? I have a 2001 STS
Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 12:21 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.