bad idle. please help

  #1  
Old 01-08-2008, 07:24 PM
Thread Starter
Join Date: Apr 2007
Location:
Posts: 25
Default bad idle. please help

what im working with is a 89 fleetwood fwd with a 4.5 Ok so i bought this used card for 1500.00 and it drove fine when i bought it. well the next day its started to stumble on acceleration then got worse to a point where i would just have the gas all the way down with the car going about 15mph.So then i changed the sparkplugs,wires, cap,rotor,fuel filter.Then it wouldnt start after all that has been changed. After replacing the ignition module and reset timeing with the rotor under #1 sparkplugposition on cap and lining up the mark on the crank shaftpully to the first mark on the little indicator it stared up just fine with a smooth idle.Then after about a min. it just acts up at idle and driving.At idle it will just stumble and choke as if it wants to turn off but then jumps back up.Even if i try to stomp the gas all the way in park it will just choke and only idle fine when it wants to. I cant figure out whats wrong after trying a diff ecm and map sensor. could it be bad cam lobes or sticking valves? pls help thks
 
  #2  
Old 01-08-2008, 07:37 PM
slowroll's Avatar
Tech Certified Members
Join Date: Oct 2007
Location: in the mitten
Posts: 3,160
Default RE: bad idle. please help

Check for codes, check connectors for injectors are fully seated, and fuel pressure.
 
  #3  
Old 01-17-2008, 08:03 PM
Thread Starter
Join Date: Apr 2007
Location:
Posts: 25
Default RE: bad idle. please help

well i finally got a chance to work on my car again and i got it going again.the problem was a brand new defective coil i had bought at auto zone. since the coil was brand new i never suspected this to be the problem,until i used a friends coil just to see if it will make a difference. Turns out it worked fine. I guess never trust aftermarket parts from autozone. thks slowroll for the feed back
 
  #4  
Old 01-18-2008, 12:46 AM
Tech Certified Members
Join Date: Jul 2006
Posts: 424
Default RE: bad idle. please help

Hey Cadworks: It's not just Auto Zone parts, I'm finding problems with parts from a number of places. Just experienced crossfiring with a new distributor cap and rotor kit. Changed it and the thing ran like new again, about two weeks later the same thing again, so put on the parts that I got back on warranty, runs like new again. Go freekin' figure, and what a waste of time.
 
  #5  
Old 07-04-2008, 12:13 PM
Thread Starter
Join Date: Apr 2007
Location:
Posts: 25
Default RE: bad idle. please help

ok its been awhile that ive been meaning to update this but havent been working on this car in a while and finally got around to it.(89 fleetwood fwd 4.5) Well after changing the coil the problem came right back after just replacing the whole distributor, new fuel pump,strainer,fuel filter. the car started just fine and went up and down the block for a test. the car ran strong twice up and down the block and then it start to lack power and pop and backfire. so i turn it off let it rest for about 20min. then try again and she runs fine forfirst 5min then acts up. i notice when im getting ready to pull out the drive way when i press the brakes to put in drive the big red brake light come on in the dash for like 3 sec the goes away and happens each time i press the brake and hear a weird hum noise and seems to affect idle. when she starts acting up at idle i rev it up a little and wont let me it starts choking and backfires a little. any guess what could be going on guys. i keep spending money on this car and just about ready to give her up. pls help.
 
  #6  
Old 07-04-2008, 12:17 PM
Thread Starter
Join Date: Apr 2007
Location:
Posts: 25
Default RE: bad idle. please help

oh i forgot to mention while i press the brake when the brake light comes on in the dash the lights flicker like the a/c reading and gas used, u know the digital readings on the dash.
 
  #7  
Old 07-07-2008, 06:45 PM
Thread Starter
Join Date: Apr 2007
Location:
Posts: 25
Default RE: bad idle. please help

anyone...
 
  #8  
Old 07-16-2008, 06:28 PM
Thread Starter
Join Date: Apr 2007
Location:
Posts: 25
Default RE: bad idle. please help

ok then thanks for feedback!
 
  #9  
Old 07-16-2008, 10:30 PM
slowroll's Avatar
Tech Certified Members
Join Date: Oct 2007
Location: in the mitten
Posts: 3,160
Default RE: bad idle. please help

Check grounds,esp battery cable to block, there is a tsb, brake light / hum noise does car have abs ?,if so TEVES abs pump motor coming on. It may not be related to driveability concern. a/c control head and FDC flashing - bcm or ground issue check for codes.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
astrodan13
Aluminum Block V8s
4
06-14-2011 12:24 AM
fabes
General Tech
11
10-29-2009 12:05 AM
Cadillac Al
General Tech
7
11-30-2008 02:56 PM
stomper
Sight n Sounds
0
03-03-2008 10:14 PM
sonotech
Cadillac CTS
3
01-05-2008 07:05 PM


Thread Tools
Search this Thread
Quick Reply: bad idle. please help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.