Po758 - Cadillac Forum - Enthusiast forums for Cadillac Owners


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-16-2017, 09:03 PM
kickasscadillac's Avatar
Member
Thread Starter
 
Join Date: Aug 2016
Location: Plymouth, WI
Posts: 57
Question Po758

I just replaced the 2 Shift Solenoids in my 99 Eldorado. It was showing a PO758 shift solenoids code. I took it out for a drive and it will not shift into the 3rd gear going down the hiway yet?? I hooked up my scan tool while driving and when I clear the code it does shift into the higher gear and just motors down the hiway fine for a bit then it kicks the code and back to square one again. I can clear the code many times and that works but the code always pops back? I know theres like 2 other solenoids in the Side cover and Im wondering if I gotta replace those??? Any help on this is appreciated...Thanks
Reply With Quote
  #2  
Old 04-17-2017, 07:22 PM
slowroll's Avatar
Tech Certified Members
 
Join Date: Oct 2007
Location: in the mitten
Posts: 2,978
Default

I would review you previous solenoid repair
Reply With Quote
  #3  
Old 04-17-2017, 11:30 PM
kickasscadillac's Avatar
Member
Thread Starter
 
Join Date: Aug 2016
Location: Plymouth, WI
Posts: 57
Question

Thanks for the reply...Im gonna elaborate a bit. I dropped the pan, found the 2 solenoids and tried to remove them. i did not know that a metal clip held them in and that it needed to be removed from the top of the valve body. I broke the old solenoids out in pieces and pulled the clip out of the solenoid hole. I went and ordered the GM solenoids and then found out about dropping the valve body. So I carefully removed the bolts for the valve body and lowered it over the drain pan. I see that the valve body is in 2 pieces. I ordered the "gasket" for the valve body as someone hear suggested but after seeing that the "gasket" is between the 2 valve body pieces and is also the metal plate i did NOT separate the 2 or use the new "gasket". Once again..I never separated the valve body. BUT!!!....later as I was cleaning the valve body in front of the car I noticed a tiny metal ball about 1/8" laying under the car. I freaked out because I know there are like 10 or so "check *****" in the valve body on that plate..which i never took apart!! Heres the thing...I VAGUELY remember something dropping out of the solenoid when I was breaking it apart...is there a "ball" in the solenoids???
I looked at the FSM for the Ball locations and all I see is them IN the valve body associated with the plate. I checked an double checked the illustrations for the parts in the solenoid channels and if it couldve came out of another port or channel and I see no ***** in any of those areas. This is why I was thinking another solenoid is bad?? I am not gonna take it to a trans shop and get raped on a repair. Any good transmission help or knowledge of this is greatly appreciated!!! Thanks in advance...Dan
Reply With Quote
  #4  
Old 04-18-2017, 11:49 AM
slowroll's Avatar
Tech Certified Members
 
Join Date: Oct 2007
Location: in the mitten
Posts: 2,978
Default

Check ***** can also be to the transmission case. The solenoids in the side cover should be ok, they will set different codes. You have a FSM so I would study the DTC description and chart. also the repair procedure to see if you over looked something. There was a TSB related to broken solenoids and a bracket intended to keep solenoids in place. You may need to go to a repair shop, or find someone more knowledgeable to help you.
Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:52 AM.