Cadillac Deville The flagship luxury car, offering the class with which the Cadillac has been associated, for decades

01 Deville instrument cluster, HVAC display dark

  #1  
Old 06-23-2019, 08:58 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 3
Default 01 Deville instrument cluster, HVAC display dark

I have searched and searched for help on this problem. 2001 Cadillac Deville

About a year ago, my instrument cluster and HVAC controls went dark. About a day later they were back on and never turned off again...until last Friday. This time they did not come back on. I was turning the ignition on/off a few times to check a brake fluid sensor warning message (to see if I corrected the problem replacing the sensor on the brake reservoir that was giving me problems) and suddenly the Attempted Theft warning came on the dash. Then everything went dark. I have checked all fuses, and swapped some relays in both fuse boxes to see if I could find the problem. No such luck. Today my digital dash is dark and HVAC is also dark yet everything is working fine. I went to a dealership and they thought it may be the ignition module and stated that they would recommend replacing that first so they have a place to start troubleshooting from. I do not think it is the ignition module but I ordered a new one which will be here in a few days. This absolutely baffles me since everything was working fine prior and all digital gauges on both displays were working fine prior to Friday. I have been reading lots and lots of posts on individuals who had similar type issues. No solutions. I have also done the battery disconnect/hard reset touch red and black together to drain computers. etc. for several minutes also...didn't work. Need help solving this one please.
 
  #2  
Old 06-24-2019, 08:34 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 3
Default

Well today I was driving and all of a sudden everything just popped back on. Full instrumentation and HVAC back. Don't know how long it will work, but it's back for now. Ignition Module still coming this week so we will replace when it arrives but if it stays working there will be no way to verify it is a fix or not. But clearly we know its not a fuse. Any input would be appreciated.
 
  #3  
Old 06-28-2019, 12:10 AM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 3
Default

Installed new Ignition Module today, running good, but then it fixed itself a few days ago so cannot tell if this fixed it or not. Time will tell.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cadillacshu
General Tech
0
01-10-2019 08:18 PM
Msoldner
Cadillac Deville
3
07-20-2017 01:14 PM
Caddi06
Cadillac Eldorado
0
09-19-2008 05:43 PM
madmatt2024
Cadillac Deville
1
01-01-2007 01:28 AM
house1000sleeved
Cadillac Seville
1
06-28-2006 05:52 AM


Thread Tools
Search this Thread
Quick Reply: 01 Deville instrument cluster, HVAC display dark


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.