67 DeVille - Gauges not working - Page 2 - Cadillac Forum - Enthusiast forums for Cadillac Owners


Reply
 
 
 
Thread Tools Search this Thread
  #11  
Old 08-29-2017, 05:50 PM
Junior Member
Thread Starter
 
Join Date: Jun 2017
Posts: 13
Default

What I'm seeing
Attached Thumbnails
67 DeVille - Gauges not working-20170829_183910.jpg  
Reply With Quote
  #12  
Old Today, 06:41 PM
Junior Member
Thread Starter
 
Join Date: Jun 2017
Posts: 13
Default

Is there a more active forum?

Installing autometer gauges. I have a shop manual. Looks like the oil pressure switch is right in the rear of the engine on top? Right in front of the firewall?

Water temp sensor I thought was on the water pipes but I don't see anything on mine. I did find a pro on the drivers head, inside...between the head and the oil filler pipe. Is this the water temp sensor?
Attached Thumbnails
67 DeVille - Gauges not working-20170921_185207.jpg   67 DeVille - Gauges not working-20170921_185150.jpg  
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Gauges Don't Light Up 1970 Eldorado frankns General Tech 0 05-20-2014 12:07 PM
Can I Swap My Digital Dash For Analog Gauges?? Joe2002DeVille General Tech 2 05-18-2010 09:23 PM
1994 eldorado, heater stays on-gauges off rbradney General Tech 1 10-11-2007 10:56 PM
92 Eldorado: gauges bump, things stop working Pizzaman Cadillac Eldorado 0 09-29-2007 02:08 AM
electrical gauges simba General Tech 0 05-21-2006 03:47 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:58 PM.