Go Back   Cadillac Forum - Enthusiast forums for Cadillac Owners > General Cadillac Forums > Member Introduction
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-14-2010, 04:08 PM
Junior Member
 
Join Date: Jun 2010
Posts: 2
Post 1995 cadillac seville! Service Ride Control?

I have a 1995 cadillac seville sts and it has a message SERVICE RIDE CONTROL. Any suggestions on how to fix this problem car runs and drives great.
Reply With Quote
  #2  
Old 06-14-2010, 08:30 PM
92_Daddylac's Avatar
Tech Certified Members
 
Join Date: Nov 2006
Location: Columbus Ne
Posts: 407
Default

most likely the rear struts are in need of replacement and compressor is worn out. this most likely will cost over $1000 in repairs. i replaced the rear struts on mine for about $800 bucks from my local parts store. and the compressor will have to be bought at a dealer ship or online. if thats all replaced and the sensors are working then it should solve the problem. if you can, go to autozone or o'reily auto parts and ask them to pull the codes with a scan tool and post what you come up with. this will tell you more of what the suspensions is doing.
__________________
Daddylac
http://www.cardomain.com/ride/3193930

Last Owned Caddy- 98' Seville SLS (SOLD 2-15-12)
Other Caddy's- 92' Deville (R.I.P.), 89 Brougham
Good info for all of us caddy owners click here: http://www.cadillacforum.com/forum/s...ad.php?t=11803
Check out the Forum on Facebook: http://www.facebook.com/pages/Cadill...294488?sk=wall
Reply With Quote
  #3  
Old 06-15-2010, 12:40 PM
Junior Member
 
Join Date: Jun 2010
Posts: 2
Default Service ride control

Quote:
Originally Posted by 92_Daddylac View Post
most likely the rear struts are in need of replacement and compressor is worn out. this most likely will cost over $1000 in repairs. i replaced the rear struts on mine for about $800 bucks from my local parts store. and the compressor will have to be bought at a dealer ship or online. if thats all replaced and the sensors are working then it should solve the problem. if you can, go to autozone or o'reily auto parts and ask them to pull the codes with a scan tool and post what you come up with. this will tell you more of what the suspensions is doing.
Thanks for the help daddylac
Reply With Quote
Old 06-15-2010, 12:40 PM
 
 
 
Reply



Tags
1995, cadillac, cadillacforums, compressor, control, deville, escalade, forum, issues, message, ride, service, seville, sls, sts


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 02:19 PM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.