Go Back   Cadillac Forum - Enthusiast forums for Cadillac Owners > General Technical Section > General Tech
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-29-2010, 01:44 PM
Junior Member
 
Join Date: Mar 2010
Posts: 19
Default 90 deville wont run right.

Okay im still trying to figure out why my 90 deville wont run. I ve done a total tune up on this car had tps tested, Rechecked all plugs and wires checked fuel pressure which is good. As i was taking out plugs on the backside of my engine i noticed that the o2 sensor between the motor and the cat was broken off and just hanging from the wires. I know this needs to be replaced but is this why my car doesnt want to run worth a ****? I was on my way home from kansas city, a 3 hour drive when i just suddenly lost power. My fuel economy went from 16 miles to the gallon on the highway to around 4, Yeah 4 and i could not get my car to go over about 40 mph no matter how far i pushed the accelerator. Only code i am getting is idle control motor which needs to be replaced also but that should only effect the car at idle right? Ive adjusted the plunger where it will keep the car at idle without having to hold my foot on the gas. I cant seem to figure out why i am not getting a code for the 02 sensor being broke in half, is my ecu going bad? I heard something about blowing ecu chip from driving without o2 sensor is this true?? Someone please give me a hand here I need my lac back!!!!!!!!! I just bought it and ive only been able to put about 600 miles on it! Plus in the mean time im stuck driving wifes 95 FORD pos taurus. Someone help please!!! Thanks
Reply With Quote
  #2  
Old 03-29-2010, 08:54 PM
slowroll's Avatar
Tech Certified Members
 
Join Date: Oct 2007
Location: Mid Atlantic
Posts: 2,504
Default

O2 being broken is not good but may not cause code. With sensor out see if car has more power...If so cat.conv. is restricted. ISC code ..guessings E30... will not cause this problem, does indicate bad / slow to respond ISC. Do you have FSM ?
__________________
It will be OK
Reply With Quote
  #3  
Old 03-30-2010, 09:12 PM
Junior Member
 
Join Date: Mar 2010
Posts: 19
Lightbulb

Quote:
Originally Posted by slowroll View Post
O2 being broken is not good but may not cause code. With sensor out see if car has more power...If so cat.conv. is restricted. ISC code ..guessings E30... will not cause this problem, does indicate bad / slow to respond ISC. Do you have FSM ?

Thanks for the reply. Yes the code is e30.Today i got the car put back together got gas in it and got it to start still with no power it will start right up everytime but it didnt like to run. I ran it for probably 30 seconds or so and the whole exhaust before my cat was hot and air putts out of the tail pipe. I do not have a factory service manual all i have is a haynes. The only thing i have not tested is the ignition control module which appeared to be newer the pick up coil (Im getting good spark on all cylinders) and the map sensor. I need to know how to test the map sensor is this something autozone can do? Can i unplug when the car is running and it should die or something? When the car started to run badly i could smell gas strong and i was getting about 4 miles to the gallon on the highway. I am guessing that the o2 sensor broke off and caused an bad fuel mixture which may have caused my catalytic converter to fail i drove probably 100 miles or more dumping gas. I plan to buy a new o2 sensor if that doesnt do it i am going to unbolt and drop exhaust before the cat and see if thats my problem. Am i going the right way with this? Should i do something else first? Why am i not getting codes for these things?comments appreciated thanks

Last edited by Chris90Deville; 03-30-2010 at 09:15 PM.
Reply With Quote
  #4  
Old 03-31-2010, 08:44 PM
slowroll's Avatar
Tech Certified Members
 
Join Date: Oct 2007
Location: Mid Atlantic
Posts: 2,504
Default

From what you are discribing, if you disconnect exhaust at manifold, make sure it can't fall and hit roadway. Drive car see how it does, car will be very loud so don't try to go far...PD is not always understanding especially when you are miles from home.
__________________
It will be OK
Reply With Quote
  #5  
Old 04-02-2010, 10:39 AM
Junior Member
 
Join Date: Apr 2010
Posts: 5
Default

Yeah! But I think this is a horrible idea.
__________________
Cadillac Performance Chips
Reply With Quote
Old 04-02-2010, 10:39 AM
 
 
 
Reply



Tags
1992, 90, backside, cadillac, code, deville, e30, eldorado, engine, exhaust, manifold, o2, putting, run, sensor, tune, wont


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 04:31 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.