Go Back   Cadillac Forum - Enthusiast forums for Cadillac Owners > General Technical Section > General Tech
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-19-2008, 02:54 AM
 
Join Date: Sep 2008
Posts: 4
Default 03 CTS stalls with no warning

I have an 03 CTS w/70,000, I have owned this car since september of 07. Had no problems until 3 wks ago, my wife and me drove 45mins to visit friends. Half way home we stopped at a red light, just as I got stopped the car shut off with no warning, I had no check engine lights or nothing telling me something was wrong. I tried to restart the car, it would turn over but would not start, we coasted it to the side of the road and for hahas looked under the hood, like I was going to find what was wrong. After 15-20 mins trying and letting sit at intervals it finally started, made it home with no more problems. Drove the car off and on for the next week, no problems, until exactly 1wk later we had to go 10 mins down the road to wifes company function the car shut off again as I was slowing to a stop behind cars at a red light it shut off again when it came to low idle, again I had no warning and no warning lights on. I did notice this time under the hood 2 things 1) I had added some coolant and left the cap off (put back on) 2) the negative battery connection was just loose to where I could move it (retightened). This time however we had to wait 45 mins before the car would start (by the way we were meeting the same friends from the week before). Made it to the function which was only 2 mins from where the car stalled, as we were following cars into the parking lot at low speed, the car shut off again. The car started by the time we came back out, but this time on the way home, every time I had to go slow or stop I would put it in neutral and rev it a little to keep up the idle, it worked until I got to the top of my driveway where coming to a stop it stalled again (but at least we were home)(3 in 1 day) and it did it one more within the wk, so the car is parked for now (which I miss driving). Now my question, could this be a crank sensor issue or a fuel issue, I have read that it could be one of several different issues. Did not take to a dealer yet, new to this area, checking on 1 dealer that sounds good. Plus the cts might have to wait a week, just put $1500 into my 97 F150 which is another story.
Reply With Quote
  #2  
Old 10-25-2008, 01:28 PM
 
Join Date: Sep 2008
Posts: 4
Default RE: 03 CTS stalls with no warning

hi all,

After several attempts at trying to get codes when my car would stall, I finally succeded. I have a P0335 code (crankshaft position sensor A circuit malfunction), now is this finally telling me that I have to replace my crank sensor or could it be something else.
If it is the crankshaft sensor, are they easy to replace or should I take it to a caddy dealer.
Reply With Quote
  #3  
Old 11-09-2008, 10:23 PM
 
Join Date: Sep 2008
Posts: 4
Default RE: 03 CTS stalls with no warning

car is finally fixed.
Reply With Quote
  #4  
Old 11-02-2009, 12:46 PM
Junior Member
 
Join Date: Mar 2007
Location:
Posts: 11
Default

Quote:
Originally Posted by tafscts View Post
car is finally fixed.
Sorry for digging up the dead here, but I am currently having the same issue with the same code. Was it the the Crank Position Sensor after all?

Thanks so much.

Regards.
__________________
2003 Cadillac CTS (stock)

2000 Grand Prix GTP (Heavily Modded)
Reply With Quote
  #5  
Old 11-02-2009, 06:18 PM
Senior Member
 
Join Date: Oct 2008
Location: S.Florida
Posts: 110
Default

sorry no one got to you tafs at the time, if your still out there keep us informed on your cts, and we'll keep more eyes out. But glad you fixed it. I heard that is a very common problem for the cts, at least 03 and wud guess other years. Also heard its B*** to get at and change that sensor althou possible. 00Falcon, i wouldnt doubt it, If your mchenacilly inclined id say take a sat and change it out, should get you going smoothly again.
Reply With Quote
  #6  
Old 11-22-2010, 03:01 PM
Junior Member
 
Join Date: Nov 2010
Location: Houston TX
Posts: 1
Talking 03 cts stalls with no warning

My 03 cts had this issue, it would just die for no reason while slowing down or accelerating, while at a red light and would also hesitate to start, the code I got on my DIC was p0335c, which was the crank position sensor, so I went ahead and replaced it, when I took my old one the sensor metal tip was full of metal shavings!! I stuck a magnet in there to get the rest of the shavings out, So I'm done replacing it and as soon as I start my car I get the same crappy long crank! Checked my codes and there it was again!!! I took it apart again, thinking it had gotten more metal shavings on it, to my surprise it was clean! So I decided to change my cam position sensor (which was only like $40 at oreilleys n really easy to change) unplugged the battery for like 10 mins, turned my key to the on position, checked my codes and ..... IT WAS FIXED!
To Anybody having this problem, I'd suggest replacing both, cam n crank ps,
I hope this helps anybody!
Reply With Quote
Old 11-22-2010, 03:01 PM
 
 
 
Reply



Tags
03, caddy, cadillac, camshaft, change, crank, crankshaft, cts, escalade, location, low, position, sensor, speed, stalls


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 03:03 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.