Go Back   Cadillac Forum - Enthusiast forums for Cadillac Owners > Cadillac Models > Cadillac STS
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-13-2007, 07:01 AM
rickyd's Avatar
Tech Certified Members
 
Join Date: Jul 2007
Location: pennsylvania
Posts: 1,317
Send a message via Yahoo to rickyd
Default electric issues e-ghosts...rear integration module, (RIM)

good morning.... well now that the season is starting to change, ( nights are cooler and wet, and big moister on car in the morn) boy my electrics are wacky! fuel gauge, instrument cluster, security light, auto dr unlock, temp gauge, all have issues............ can anyone pin -point what ground or connection this might be??? there is also a relay that sometimes will buzz after shut down..... it is the cvrss dampers relay....... a simple disconnect of the battery for a whilewill shut it off. i just had it in for a service stability system dic info, that was poor grounds at g100 and g102............so anybody?............ill bestanding by..........katzmans? you out there? 1999 sts
rickyd



===============



Moderator Edit:
Title to define a particualr issue.
1999 Cadillac STS Rear Integration Module .. RIM




__________________
I had my V8 today
Reply With Quote
  #2  
Old 09-18-2007, 12:22 PM
rickyd's Avatar
Tech Certified Members
 
Join Date: Jul 2007
Location: pennsylvania
Posts: 1,317
Send a message via Yahoo to rickyd
Default RE: electric issues e-ghosts...all over

anyone out there on this one.........???????
Quote:
ORIGINAL: rickyd

good morning.... well now that the season is starting to change, ( nights are cooler and wet, and big moister on car in the morn) boy my electrics are wacky! fuel gauge, instrument cluster, security light, auto dr unlock, temp gauge, all have issues............ can anyone pin -point what ground or connection this might be??? there is also a relay that sometimes will buzz after shut down..... it is the cvrss dampers relay....... a simple disconnect of the battery for a whilewill shut it off. i just had it in for a service stability system dic info, that was poor grounds at g100 and g102............so anybody?............ill bestanding by..........katzmans? you out there? 1999 sts
rickyd
__________________
I had my V8 today
Reply With Quote
  #3  
Old 09-18-2007, 12:27 PM
stomper's Avatar
Tech Certified Members
 
Join Date: Jun 2007
Posts: 2,704
Default RE: electric issues e-ghosts...all over

Quote:
ORIGINAL: rickyd

good morning.... well now that the season is starting to change, ( nights are cooler and wet, and big moister on car in the morn) boy my electrics are wacky! fuel gauge, instrument cluster, security light, auto dr unlock, temp gauge, all have issues............ can anyone pin -point what ground or connection this might be??? there is also a relay that sometimes will buzz after shut down..... it is the cvrss dampers relay....... a simple disconnect of the battery for a whilewill shut it off. i just had it in for a service stability system dic info, that was poor grounds at g100 and g102............so anybody?............ill bestanding by..........katzmans? you out there? 1999 sts
rickyd
dang .. where was this?

i be replacing the buzzing relay yesterday,
check battery - how old is it? what type?
check alternator,
check battery ground,
check other grounds.
codes?

then report back ..





__________________
"If you're going through hell, keep going"
~ Winston Churchill


Reply With Quote
  #4  
Old 09-18-2007, 04:14 PM
rickyd's Avatar
Tech Certified Members
 
Join Date: Jul 2007
Location: pennsylvania
Posts: 1,317
Send a message via Yahoo to rickyd
Default RE: electric issues e-ghosts...all over

Stomper..... thanks for the response, it must have been an off week when i posted :-)...... buzzing relay.. tryed that, new one, did the same thing....just thought that might give someone a heads up to pinpoint....... battery, 1-2 yr old and a bigbasta-d. alternater- 2yr old..... Stomp, i know its a ground, simply because once the car is drivin, and the sun is out and all isdryed up, things are fine, with a slight bounce in the fuel gague, at times.(goes to E then back)( could it poss be the sending unit???, and would that inturn through other things off?)..... i know there are about 15 grounds on the car (99 sts). g100, g102 have been redone a short time ago(service stability system)...... which one, or where do you think i should look now? as far as codes????? i'll have to check them (if i remember how) when i get back home. out of town for the week..... THANKS again.....
rickyd
__________________
I had my V8 today
Reply With Quote
  #5  
Old 09-18-2007, 06:42 PM
stomper's Avatar
Tech Certified Members
 
Join Date: Jun 2007
Posts: 2,704
Default RE: electric issues e-ghosts...all over

Quote:
ORIGINAL: rickyd

Stomper..... thanks for the response, it must have been an off week when i posted :-)...... buzzing relay.. tryed that, new one, did the same thing....just thought that might give someone a heads up to pinpoint....... battery, 1-2 yr old and a bigbasta-d. alternater- 2yr old..... Stomp, i know its a ground, simply because once the car is drivin, and the sun is out and all isdryed up, things are fine, with a slight bounce in the fuel gague, at times.(goes to E then back)( could it poss be the sending unit???, and would that inturn through other things off?)..... i know there are about 15 grounds on the car (99 sts). g100, g102 have been redone a short time ago(service stability system)...... which one, or where do you think i should look now? as far as codes????? i'll have to check them (if i remember how) when i get back home. out of town for the week..... THANKS again.....
rickyd
please dont take offense, but on that note, please go here and see what can be done ..

http://www.cadillacforum.com/m_9792/tm.htm





.
__________________
"If you're going through hell, keep going"
~ Winston Churchill


Reply With Quote
  #6  
Old 09-18-2007, 08:56 PM
Katzmans Caddy's Avatar
Super Moderator
 
Join Date: Dec 2006
Location: Toronto, CANADA
Posts: 1,452
Default RE: electric issues e-ghosts...all over

Got my own electrical Gremlins, rickyd, but not for this post.No one has ever called me Sparky, but I did track down a short in my daughter's Buick brake lighting system once, took over an hour and a half.
__________________
2006 DTS Performance - L37 32v Northstar NHP V8 292 HP - 1 of 1
1999 STS - L37 32v Northstar V8 300 HP
1998 Deville D'Elegance - LD8 32v Northstar V8 (Sold July 9, 2011 with 225,000 km)
1993 Fleetwood - L05 5.7 TBI V8 (Sold July 18, 2012 with 308,000 km)
1999 GMC Suburban SLT- 5.7 Vortec
1998 Olds 88 LS - Series II 3.8 V6
1973 Pontiac LeMans GT - 454 V8 1 of less than 5
Reply With Quote
  #7  
Old 09-19-2007, 09:55 AM
rickyd's Avatar
Tech Certified Members
 
Join Date: Jul 2007
Location: pennsylvania
Posts: 1,317
Send a message via Yahoo to rickyd
Default RE: electric issues e-ghosts...all over

Stomper, yes you are correct..... i knew when i typed that, that i shouldn't have..... though wanted to give heads up that the problem hits that relay, and may give a clue to the e-ghost...... i should have said i have exchanged relays, and found nodifference, or no fix to thee-ghost problem......that being said, i have read the post..9792/tm.htm and agree 100%..... all of our timeis limitedand sure don't want to waist anyones, especially looking for help. i didn't take offence, and thank you for your response.... i will, as i said get codes for you all to review when i return home saturday.....i hope you will assist my e-ghost problem at that time.
i have done the internal code check from inside the car1 time.... would you please refresh my memory on that please..... sorry for the past post
rickyd hey Katz....trying to get all you guys straight...........
__________________
I had my V8 today
Reply With Quote
  #8  
Old 09-19-2007, 10:24 AM
stomper's Avatar
Tech Certified Members
 
Join Date: Jun 2007
Posts: 2,704
Default RE: electric issues e-ghosts...all over

Quote:
ORIGINAL: rickyd

Stomper, yes you are correct..... i knew when i typed that, that i shouldn't have..... though wanted to give heads up that the problem hits that relay, and may give a clue to the e-ghost...... i should have said i have exchanged relays, and found nodifference, or no fix to thee-ghost problem......that being said, i have read the post..9792/tm.htm and agree 100%..... all of our timeis limitedand sure don't want to waist anyones, especially looking for help. i didn't take offence, and thank you for your response.... i will, as i said get codes for you all to review when i return home saturday.....i hope you will assist my e-ghost problem at that time.
i have done the internal code check from inside the car1 time.... would you please refresh my memory on that please..... sorry for the past post
rickyd hey Katz....trying to get all you guys straight...........

I get this feeling that you are becoming a valuable asset to this site. You learn as you go and dont wear a chip on your shoulders. Those are very valuable traits in this community.

Of course we will help where we can. Time, as you mentioned, is limited. We all have real jobs and come here as "volunteers" .. right?






__________________
"If you're going through hell, keep going"
~ Winston Churchill


Reply With Quote
  #9  
Old 09-19-2007, 10:59 AM
rickyd's Avatar
Tech Certified Members
 
Join Date: Jul 2007
Location: pennsylvania
Posts: 1,317
Send a message via Yahoo to rickyd
Default RE: electric issues e-ghosts...all over

thanks stomoper..... i to am working and grabbing a minute or two or three to look in....see whats up. i enjoy the Forum a ton, and like to help.....only when i"ve been there, if you know what i mean......
thanks again........oh getting codes from with- in the car....99sts..... which thread or post..please direct me.
rickyd
__________________
I had my V8 today
Reply With Quote
  #10  
Old 09-23-2007, 08:23 AM
rickyd's Avatar
Tech Certified Members
 
Join Date: Jul 2007
Location: pennsylvania
Posts: 1,317
Send a message via Yahoo to rickyd
Default RE: electric issues e-ghosts...all over

Stomper.....so i'm back in town and with the sts......however, while gone the week, i hadmy lady friend run the sts for me.......well, as she stated..she started it and run it down the block, and back and shut it off...... well when she went out friday...it would not start...... my fault, i should have told her to at least get the car warmed up, or to take it to work, etc.....imo the cvrss relay stuck on and killed the batt...... sunday morning, start right up with jump and ran new..... though maybe, she somehow disabled the starter, because the batt seems to be back up in just a 3 mi jont...
so, iran codes.....yikes!!!! stomper it seemed as i told it to do "all"EVERY code came up in history. i couldn't write them all down........ PLUS, and this really pi____ me off. the sts hasa couple spots of oil under it...taat N* is spotless.....i sure hope it was from me topping it off before i left for the week.. ill have to watch it.......so bad to the codes.... i'll drive it today and see what if anything pops up that i can get a code from, this is good because i reset all codes and hopefully the one that pops up will give us a starting point ......tell me if i'm wrong in thinking that.......is there any one catigory i should be looking for??????......yea, if you don't mind' stick with me here, and i'll be back at ya with this.....stomp, thanks alot
rickyd>>>>>> hey,? that cvrss relay that buzzes, only 4 times sense Jan 07. should itbe replaced, i did get a new one and put in in and it buzzed like the old one.the guy was nice enough to take it back and i returned it...... that seems to buzz onlywhen the e-ghosts are all most visible.(all is going hay-wire)..... :-) tx again
__________________
I had my V8 today
Reply With Quote
Old 09-23-2007, 08:23 AM
 
 
 
Reply



Tags
1999, author, cadillac, cadilliac, cts, cvrss, dampers, deville, integration, intergration, module, problems, rear, rickyd, rim


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 10:08 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.