Go Back   Cadillac Forum - Enthusiast forums for Cadillac Owners > General Technical Section > Braking System
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-24-2011, 01:49 PM
Junior Member
 
Join Date: Aug 2011
Posts: 1
Default 2002 Escalade Service Stability System

I know I have read through a hundred posts on this same issue, with no luck of finding the fix. After starting my truck, and pulling away at a low speed, it jerks like something is grabbing, then stops and as I accelerate, the light comes on. When slowing down, I can feel the brake pedal "grind" like they are anti-locking. We took it the dealer and they said it was the Brake pressure modulator switch. So we replaced that and it is still doing the same thing, only now the brake pedal felt really stiff, almost as if I couldn't push it at all, after pulling out at a low speed. I was just wondering if anyone found a fix?? Any help would be greatly appreciated
Reply With Quote
Old 08-24-2011, 01:49 PM
 
 
 
Reply



Tags
02, 2002, brake, cadallac, cadillac, code, escalade, fix, light, pump, service, sistem, slows, stability, system


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 06:51 PM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.